Ocularis 5.5 License Upgrade Request Form

Please complete the form below. For further assistance, feel free to contact us. Our business hours are Monday through Friday, 9:00 AM to 5:00 PM, EST.

If you are looking to upgrade to an earlier software version, please follow this link.


I understand that Ocularis 5.5 does not support discontinued Microsoft products, including Windows Server 2008, Windows 8, or any operating system older than Windows 7 SP1 and Server 2008. I confirm that all operating systems that will be running Ocularis 5.5 meet the required specifications. See Ocularis Hardware Recommendations for more information.